package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(/.*)@gram_bot|(/.*))`)
var str = `/echo@gram_bot
/echo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}