$re = '/(?:(\d+) Days?)?(?: ?(\d+) Hours?)?(?: ?(\d+) Minutes?)?/m';
$str = '142 Days 16 Hours
128 Days 9 Hours 43 Minutes
10 Minutes
48 Hours
1 Day 1 Hour 0 Minutes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);