use strict;
my $str = '21. The SBSTA considered this agenda item at its 1^st^ meeting and resumed 3^rd^ meeting, on 15 November. It had before it document FCCC/SB/2016/3. At its 1^st^ meeting, the SBSTA agreed to consider this agenda item together with agenda item 11 of the SBI in informal consultations co-facilitated by Ms. Beth Lavender (Canada) and Mr. Alf Wills (South Africa). As referred to by the COP,[^18] the SBSTA also considered the issue of the review of the Warsaw International Mechanism for Loss and Damage associated with Climate Change Impacts, and agreed that it would be discussed at the same informal consultations. At its resumed 3^rd^ meeting, the SBSTA recommended two draft decisions on these matters for consideration and adoption at COP 22.[^19]. Mr. Seen and Mr. Conwell participate actively to the reconciliation.
Mr. Raúl Estrada-Oyuela (Argentina)
';
my $regex = qr/(M[rs].\s\w+(?:\s[\w-]+)(?:\s\([^\)]*\))?)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}