$re = '/(?<=\)).*/m';
$str = 'Awesome (8433) Stuff.I.Want.to.Delete';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);