package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(https?|ftp)://(-\.)?([^\s/?\.#-]+\.?)+(/[^\s]*)?$`)
var str = `http://www.itzhak.co.il
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}