$re = '/[^a-z0-9%*][a-z0-9%]{3,}(?=[^a-z0-9%*])/m';
$str = '^asdf^1234^56as^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);