re = /^([A-Za-z0-9_\-\.])+\@([A-Za-z0-9_\-\.])+\.([A-Za-z]{2,6})$/m
str = 'test@tatsu.works'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end