const regex = /\d\d\d\d-\d\d-\d\d/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\d\\d\\d-\\d\\d-\\d\\d', '')
const str = `2013-07-28 dfsd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}