# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$organization\['(.*?)'\]"
test_str = ("<?php $view->extend('layout.html.php') ?>\n"
"<div class=\"boxContainer contentContainer textContainer\">\n"
" <?php //echo $this->partial('common/notifications.phtml', 'default',\n"
" //array('messages' => $this->notificationMessages)); ?>\n"
" <?php echo $view->render(':scripts:common/notifications.html.php') ?>\n\n"
" <h2 class=\"contentHeader\"><span><?php echo $view['translator']->trans('om.organization.detail.heading', [], 'om');?></span></h2>\n"
" <div class=\"detail\">\n\n"
" <!-- Organization -->\n"
" <?php if (!empty($organization['Name'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.name', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.name.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Name']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (isset($organization['Active'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.active', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.active.tooltip\"></span></span>\n"
" <span class=\"field\"><?php /* @fixme echo $this->stateImage($organization['Active'] ? 'ACTIVE' : 'INACTIVE') .\n"
" ' ' . $this->booleanMessage($organization['Active']); */?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Type'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.type', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.type.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($view['translator']->trans('om.organization.type.' . $organization['Type'], [], 'om')); ?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['OwnerOrganizationId'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.ownerOrganization', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.ownerOrganization.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php // echo $this->entityReference('organization', $organization['OwnerOrganizationId']); ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($childOrganizations)): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.childOrganizations', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.childOrganizations.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php for ($i = 0; $i < count($childOrganizations); $i++): ?>\n"
" <?php\n"
" echo $childOrganizations[$i]['name'];\n"
" ?>\n"
" <?php if ($i < count($childOrganizations) -1 ): ?>, <?php endif; ?>\n"
" <?php endfor; ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['CountryIds'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.countryIds', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.countryIds.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php foreach ($organization['CountryIds'] as $countryId): ?>\n"
" <?php // echo $view->escape($this->country($countryId)->getCountryName()); ?><br />\n"
" <?php endforeach; ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['LanguageCodes'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.languageCodes', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.languageCodes.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php\n"
" for ($i = 0; $i < count($organization['LanguageCodes']); $i++) {\n"
" if (!empty($organization['LanguageCodes'][$i])) {\n"
" // echo $this->entityReference('language', trim($organization['LanguageCodes'][$i]));\n"
" if ($i !== count($organization['LanguageCodes']) - 1) {\n"
" echo ', ';\n"
" }\n"
" }\n"
" }\n"
" ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Roles'])):?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.person.roles', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.roles.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php for ($i = 0; $i < count($organization['Roles']); $i++) :?>\n"
" <?php echo $organization['Roles'][$i]['name']; ?>\n"
" <?php if ($i < count($organization['Roles']) -1): ?>, <?php endif; ?>\n"
" <?php endfor;?>\n"
" </span>\n"
" </div>\n"
" <?php endif;?>\n"
" <?php if ($organization['Type'] === 'POS' & !empty($organization['Flags'])): ?>\n"
" <?php foreach($organization['Flags'] as $flag): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.' . $flag);?><span data-igo-help-tooltip=\"help.om.organization.<?= $flag ?>.tooltip\"></span></span>\n"
" <span class=\"field\">Yes</span>\n"
" </div>\n"
" <?php endforeach; ?>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['LogotypeFilename'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('image', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.logotypeFilename.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php if ($organization['LogotypeFilename']): ?>\n"
" <img src=\"<?php echo $view->escape($organization['LogotypeFilename']); ?>\"\n"
" alt=\"<?php echo $view->escape($organization['Name']); ?>\"\n"
" title=\"<?php echo $view->escape($organization['Name']); ?>\"/>\n"
" <?php endif; ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Description'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.description', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.description.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Description']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['CustomCardType'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.customCardType', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.customCardType.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['CustomCardType']); ?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['ContractStartDate'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.contractStartDate', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.contractStartDate.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['ContractStartDate'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['ContractEndDate'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.contractEndDate', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.contractEndDate.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['ContractEndDate'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['MamutId'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.mamutId', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.mamutId.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['MamutId'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['ContactEmail'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.contactEmail', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.contactEmail.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['ContactEmail'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <hr />\n"
" <!-- Contact attributes -->\n"
" <?php if (!empty($organization['Address1'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.address1', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.address1.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Address1']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Address2'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.address2', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.address2.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Address2']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($this->postalCode['cardType'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.postalCode', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.postalCode.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['PostalCode']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['CityGeoId'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.cityGeoId', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.cityGeoId.tooltip\"></span></span>\n"
" <span class=\"field\"><?php // echo $view->escape($this->city($organization['CityGeoId'])->getCityName());?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Phone'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.phone', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.phone.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Phone']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Fax'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.fax', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.fax.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Fax']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['Email'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.email', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.email.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $view->escape($organization['Email']);?></span>\n"
" </div>\n"
" <?php endif; ?>\n\n"
" <!-- Operational attributes -->\n"
" <hr />\n"
" <?php if (!empty($organization['CreatedDate'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.createdDate', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.createdDate.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['CreatedDate'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['LastModifiedDate'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.lastModifiedDate', [], 'om');?><span data-igo-help-tooltip=\"help.om.organization.lastModifiedDate.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['LastModifiedDate'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['LastModifiedByUserId'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('lastModifiedByUser', [], 'common'); ?><span data-igo-help-tooltip=\"help.om.organization.lastModifiedByUser.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php // echo $this->entityReference('user', $organization['LastModifiedByUserId']); ?>\n"
" </span>\n"
" </div>\n"
" <?php endif; ?>\n\n"
" <!-- Additional organization info -->\n"
" <?php if (!empty($organization['Websites']) ||\n"
" !empty($organization['TwitterLink']) ||\n"
" !empty($organization['FacebookLink']) ||\n"
" !empty($organization['StudentPopulation']) ||\n"
" !empty($organization['CardRetailSellingPrice'])): ?>\n"
" <hr />\n"
" <?php endif; ?>\n"
" <?php if (!empty($organizationWebsites)): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.website', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.website.tooltip\"></span></span>\n"
" <span class=\"field\">\n"
" <?php for ($i = 0; $i < $websitesCount = count($organizationWebsites); $i++) :?>\n"
" <a href=\"<?php echo $organizationWebsites[$i]; ?>\" target=\"_blank\"><?php echo $organizationWebsites[$i]; ?></a>\n"
" <?php if ($i != $websitesCount - 1) {\n"
" echo(\", \");\n"
" } ?>\n"
" <?php endfor;?>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['TwitterLink'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.twitterLink', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.twitterLink.tooltip\"></span></span>\n"
" <span class=\"field\"><a href=\"<?php echo $organization['TwitterLink'];?>\" target=\"_blank\"><?php echo $organization['TwitterLink'];?></a></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['FacebookLink'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.facebookLink', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.facebookLink.tooltip\"></span></span>\n"
" <span class=\"field\"><a href=\"<?php echo $organization['FacebookLink'];?>\" target=\"_blank\"><?php echo $organization['FacebookLink'];?></a></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['StudentPopulation'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.studentPopulation', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.studentPopulation.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['StudentPopulation'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" <?php if (!empty($organization['CardRetailSellingPrice'])): ?>\n"
" <div class=\"fieldRow\">\n"
" <span class=\"label\"><?php echo $view['translator']->trans('om.organization.cardRetailSellingPrice', [], 'om'); ?><span data-igo-help-tooltip=\"help.om.organization.cardRetailSellingPrice.tooltip\"></span></span>\n"
" <span class=\"field\"><?php echo $organization['CardRetailSellingPrice'];?></span>\n"
" </div>\n"
" <?php endif; ?>\n"
" </div>\n"
"</div>\n"
"<?php if (Default_Model_SecurityUtils::hasPermission('ROLE_OM_ORGANIZATION_READ')): ?>\n"
"<div class=\"pageControls\">\n"
" <div class=\"left\">\n"
" <?php // @FIXME $defaultBackUrl = $this->url(array('controller' => 'organizations', 'action' => 'search', 'module' => 'om'), 'default'); ?>\n"
" <a class=\"btn btn-link\" href=\"<?php // echo $this->backUrl($defaultBackUrl); ?>\"><?php echo $view['translator']->trans('back', [], 'common'); ?></a>\n"
" </div>\n"
" <div class=\"right\">\n"
" <?php\n"
" // @FIXME $targetUrl = $this->url(array('action' => 'edit', 'id' => $organization['OrganizationId']), 'resource');\n"
" ?>\n"
" <?php //@FIXME echo $this->renderButton('edit', array('style' => 'wlw', 'align' => 'right',\n"
" //'href' => $this->backUrlAppend($targetUrl))); ?>\n"
" </div>\n"
" <div class=\"clearer\"></div>\n"
"</div>\n"
"<?php endif; ?>\n")
subst = "\\$organization->get$1()"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.