using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\.]+)\.([^\[]+| ?)(.*)";
string input = @"A.Dashev-1[ТП-5.2 AC]C_active_power";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}