#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w\+\-]+\.\w+\.(?<EPOCH>\d+)(?<AV>\.av)?\.mat"
Local $sString = "AvAnalysisTill20Kepoch_onlyW.png" & @CRLF & _
"Program.30_07_2017_14_03_31.1.json" & @CRLF & _
"Program.30_07_2017_14_03_31.1.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10002.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10005.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10005.av.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10005.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10008.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10011.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10014.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10017.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.1002.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10020.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10023.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10026.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10029.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10032.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10035.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10038.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10041.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10044.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.10047.mat" & @CRLF & _
"Program.30_07_2017_14_03_31.1005.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19950.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19953.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19956.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19959.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19962.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19965.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19968.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19971.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19974.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19977.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19980.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19983.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19986.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19989.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19992.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19995.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19998.mat" & @CRLF & _
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.20000.mat" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")