package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*:(.*).tst$`)
var str = `Banjo.ald:Mandolin.ald:Guitar.tst`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}