#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/?(b|color|i|size)(=.*?)?>"
Local $sString = "<color=#he>x>>" & @CRLF & _
"<color=red>>>>" & @CRLF & _
"<b>" & @CRLF & _
"<i>" & @CRLF & _
"</b>" & @CRLF & _
"</i>" & @CRLF & _
"</color>" & @CRLF & _
"<size=13>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")