$re = '/(?<!(<\/?|<.+?>))\p{L}+(\p{P}?\p{L}+)+(?!(<\/|\/?>))/u';
$str = '<pb/>Перекати<s>Pиo-дe-Жaнeйpo.</s> Перекати-поле;<span>поле</span>полe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);