import re
regex = re.compile(r"^(((h..ps?|f.p):\/\/)?(?:([\w\-\.])+(\[?\.\]?)([\w]){2,4}|(?:(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\[?\.\]?){3}(?:25[0-5]|2[0-4]\d|[01]?\d\d?)))*([\w\/+=%&_\.~?\-]*)$", flags=re.MULTILINE)
test_str = ("www[.]domain[.]com\n"
"www.domain.com\n"
"hxxp://www[.]domain[.]com\n\n"
"192.168.8.1/folder/file.html\n\n"
"192.168.1[.]1\n"
"192.168.1[.]1/folder/file.html\n"
"192[.]168[.]1[.]1/folder/file.html\n"
"hxxp://www[.]domain[.]com/folder/file.html\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")