$re = '/^anh/m';
$str = 'anh
yêu
em
anh yêu em';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);