$re = '/^(?!$)(?:(\d+)h\h*)?(?:(\d+)m)?$/m';
$str = '1h 31m
45m
1h 42m
2h
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);