re = /^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=\D*\d)[A-Za-z\d!$%@#£€*?&]{8,}$/m
str = 'Test1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end