package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<!--.*?-->`)
var str = `bonjour,
<!-- commentaire
très utile -->
comment allez-vous?
<!-- commentaire encore
plus utile -->
aujourd'hui`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}