$re = '/(?<=^\[|\|)[^|\[\]]*(?=\||\]$)/m';
$str = '[date|Y-m-d]
[date|Y-m-d|today]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);