re = /^[a-zA-Z0-9-_.]+$/m
str = 'gabo8-08_2017.com
gabo2k808_2017.com
gabo2k808#
gabo2k8-08_2017.com
gabo2k808
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end