$re = '/0([7,9][0]|[8][0,1])\d{8}/m';
$str = '08012345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);