import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*import.*";
final String string = "import backoff\n"
+ "from service.camera_simple.ffmpeg_dash_loop import rtsp_to_dash_loop\n"
+ "from share.settings.settings import Settings\n\n"
+ "from share.types.camera import Camera\n"
+ "from share.utils.adeck_logging.logging_subprocess import log_process_output\n"
+ "from share.utils.retry import on_backoff\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}