$re = '/^[A-Za-z0-9\',\-àâçèéêîôùû]*$/m';
$str = 'dsdsdêééà
dsdsdêééàÉd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);