package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+){0,1}[0-9]+$`)
var str = `+947777216903
947777216903
947777216903A
947777216903A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}