package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\p{L}(?:[\p{L}\p{Mark}\p{Decimal_Number}\p{Connector_Punctuation} -]*\p{L})?$`)
var str = `example
example
space--^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}