$re = '/^(?:(?!\n)[^\p{P}\p{S}]|[_-])*$/miu';
$str = 'example
example
example3
example3
example-
example_
space--^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);