package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{#(.*?)\}`)
var str = `Olá, como vocês estão? Eu queria pegar o valor entre esses colchetes {# Olá mundo} e que esse aqui {#Teste} não interferisse, e me retornasse:";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}