re = /\{#(.*?)\}/m
str = 'Olá, como vocês estão? Eu queria pegar o valor entre esses colchetes {# Olá mundo} e que esse aqui {#Teste} não interferisse, e me retornasse:";
teste com {#texto mal formado (não fecha as chaves)
{#xyz lorem ipsum sit dolor amet etc blablabla} abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end