$re = '/(?=A{3}B{2})[AB]+/m';
$str = 'AAABB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);