import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bSTATE\\s+:\\s+\\d+\\s+(\\S+)";
final String string = "TYPE : 10 WIN32_OWN_PROCESS\n"
+ " STATE : 4 RUNNING\n"
+ " (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)\n"
+ " WIN32_EXIT_CODE : 0 (0x0)\n"
+ " SERVICE_EXIT_CODE : 0 (0x0)\n"
+ " CHECKPOINT : 0x0\n"
+ " WAIT_HINT : 0x0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}