using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({.*?})|#.*";
string substitution = @"\1";
string input = @" This is 1. # Comment 1.
This is 2. # Comment 2
#Comment 3 {#Commit4}
This is 3.
# Commit5
This is 4.{#This is 5} # Commit6
#Commit7
This is 6.
# Commit8 #Commit9
#Commit10
# Commit11
#Commit12 #Commit13
{ # This is 7}; { # This is 8 } # Commit14
{# This is 9}; { # This is 10 }={# This is 11} {# This is 12}={# This is 13}# Commit15
# Commit16 {# Commit17 }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}