re = /\[img]((?:https?|ftps?):\/\/[^?&=\#\"<]*?\.(?:jpe?g|gif|png))\[\/img]/m
str = '[img]http://www. test .com/abc.jpg[/img]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end