import re
regex = re.compile(r"(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)", flags=re.MULTILINE)
test_str = ("0. discord.com/invite/InviteCode\n"
"1. discordapp.com/invite/InviteCode\n"
"2. discord.gg/InviteCode\n"
"3. .gg/InviteCode")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")