package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^^]aaa`)
var str = `aaa Matchaaa hereaaaaa tooaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}