const regex = /(0|1|2|3|4|5|6|7|8|9)
(?=.*:\1=(\w+))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0|1|2|3|4|5|6|7|8|9)
(?=.*:\\1=(\\w+))', 'gs')
const str = `0 zero
1 ichi
2 ni
3 san
4 shi
5 go
6 roku
7 shichi
8 hachi
9 kyuu
Dictionary:0=0:1=1:2=2:3=3:4=4:5=5:6=6:7=7:8=8:9=9`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);