$re = '/^(?! )9? ?\d{3}$/m';
$str = '345
9345
9 345
99345
9 345
45
3456
345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);