use strict;
my $str = 'To achieve this, I am using the regular expression /\\bsea/gmi, which works perfectly with English characters. However, it fails to produce the desired results when applied to Swedish characters, like \'ä\', \'å\', and \'ö\'. For example, if the search word is \'gen\', the postfix \'gen\' in the word \'vägen\' is incorrectly highlighted. It seems that the regular expression treats these characters as special characters or something similar. I even tried adding unicode modifier u but that didt\'t help either.
gen
gena
agen
ägen
genä
';
my $regex = qr/(?<![\p{L}\p{N}_])(?=[\p{L}\p{N}_])|(?<=[\p{L}\p{N}_])(?![\p{L}\p{N}_])/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}