import re
regex = re.compile(r"^(\d{4})(-(0[1-9]|1[0-2])(-([12]\d|0[1-9]|3[01]))([T\s]((([01]\d|2[0-3])((:)[0-5]\d))([\:]\d+)?)?(:[0-5]\d([\.]\d+)?)?([zZ]|([\+-])([01]\d|2[0-3]):?([0-5]\d)?)?)?)$", flags=re.MULTILINE)
test_str = (" 2009-12T12:34\n\n"
"2009\n"
"2009-05-19T08:39:22.000Z\n\n"
"2009-05-19\n\n"
"2009-05-19\n\n"
"20090519\n\n"
"2009123\n\n"
"2009-05\n\n"
"2009-123\n\n"
"2009-222\n\n"
"2009-001\n\n"
"2009-W01-1\n\n"
"2009-W51-1\n\n"
"2009-W511\n\n"
"2009-W33\n\n"
"2009W511\n\n"
"2009-05-19\n\n"
"2009-05-19 00:00\n\n"
"2009-05-19 14\n\n"
"2009-05-19 14:31\n\n"
"2009-05-19 14:39:22\n\n"
"2009-05-19T14:39Z\n\n"
"2009-W21-2\n\n"
"2009-W21-2T01:22\n\n"
"2009-139\n\n"
"2009-05-19 14:39:22-06:00\n\n"
"2009-05-19 14:39:22+0600\n\n"
"2009-05-19 14:39:22-01\n\n"
"20090621T0545Z\n\n"
"2007-04-06T00:00\n\n"
"2007-04-05T24:00\n\n"
"2010-02-18T16:23:48.5\n\n"
"2010-02-18T16:23:48,444\n\n"
"2010-02-18T16:23:48,3-06:00\n\n"
"2010-02-18T16:23.4\n\n"
"2010-02-18T16:23,25\n\n"
"2010-02-18T16:23.33+0600\n\n"
"2010-02-18T16.23334444\n\n"
"2010-02-18T16,2283\n\n"
"2009-05-19 143922.500\n\n"
"2009-05-19 1439,55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")