$re = '~^.*/(?=[^/]*/$)~m';
$str = 'https::abc/efg/hij/
https::abc/efg/hij/lmn/
https::abc/efg/hij/lmn/opr/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);