re = /.*?text"\s?:\s?"([\w\s]+)/m
str = '\'{"data":"1233","image":"dsfsdfsdfds"."text":"hello world"."name": "java"}\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end