$re = '/^[\W]*([\w+\-.%]+@[\w\-.]+\.[A-Za-z]{2,4}[\W]*,{1}[\W]*)*([\w+\-.%]+@[\w\-.]+\.[A-Za-z]{2,4})[\W]*$/m';
$str = 'kanhu@gmail.com, kanhu2@gmail.com, kanhu3@gmail.com,kanhu4@gmail.com,kanhu5@fff.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);