$re = '/.*\b(\w+)\b.*\1.*/';
$str = 'this is a sentence with with a dup';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);