using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:[.,]\d+)*\s*mu\b|kinetin|zeatin";
string input = @"high-frequency somatic embryogenesis was achieved from an embryogenic cell suspension culture of acanthopanax koreanum nakai. stem segments were cultured on murashige and skoog (ms) medium containing auxins and cytokinins. opaque and friable embryogenic callus formed on ms medium with 4.5 mu m 2,4-dichlorophenoxyacetic acid (2,4-d) and 2.0 mu m kinetin or zeatin, but was highest on medium containing 4.5 mu m 2,4-d alone.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}