$re = '/\\\\(?!color).*\}/m';
$str = 'text \\color{abc}text
text \\other{abc} text \\color{abc} text \\other{abc}
\\color{abc} \\footcites[abc]{hello}[abc]{abc} alkjöfalksdjfölaksdjföalksdjfölaksdjöfalksjdöflakdjsfölkj \\color{abc}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);