$re = '/(?i)(?<!up\sto\s)\b\d+\s*[GMK]B/';
$str = 'up to 12 gb
12 gb
123 mb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);