$re = '/([`\'\"]?)([\s\S]+?)\1/';
$str = '`Hel"lo` 2* "Hel`lo"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);