import re
regex = re.compile(r"(?<=videos\/|v=|youtu\.be\/)([\w-]+)")
test_str = ("https://www.youtube.com/watch?v=q07SQFmL4rM\n"
"https://www.youtube.com/watch?v=q07SQFmL4yM\n"
"https://youtu.be/qT47KF5pvfw\n"
"https://youtu.be/zImHyTyYhM8?t=4s\n"
"https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")