re = /^\s*([^_<>=]+)(_\w+)?([<>=%])(.*)$/m
str = 'MANY_TIME_T1=PANORAMA17
MANY_TIME_T2=OK STATUS
MANY_TIME_T1=PANORAMA18
MANY_TIME_T2=OK STATUS
COMMENT=OK
LAST<LIGNE1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end