using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"parent {[\s\S]*type.*[\s\S]*subtype.*[\s\S]*element.*[\s\S]*attributes.*[\s\S]*value testvalue.*[\s\S]*owner person1";
string input = @"parent {
type {
subtype TestSubType {
element TestElement {
attributes {
name testname;
description testdescription;
count 1234;
value testvalue;
}
owner person1;
}
}
subtype TestSubType2 {
element TestElement2 {
attributes {
name testname2;
description testdescription2;
count 2;
value 2
}
owner unknown;
}
}
}
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}